After SCCM Site recovery cannot login to Console

Question

Hi Team, thanks for the awesome place for Configmgr admins. I am trying to replicate a production environment using database backup. After successful restoration, I am not able to login to the console. I ran command get-cmadministrativeuser but its blank. When I run following command, it errors out

PS PR1:> New-CMAdministrativeUser -Name domainuser -RoleName “full administrator”
New-CMAdministrativeUser : No object corresponds to the specified parameters.
At line:1 char:1
+ New-CMAdministrativeUser -Name domainuser -RoleName “full administrator”
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (Microsoft.Confi…tiveUserCommand:NewAdministrativeUserCommand) [New-CM
AdministrativeUser], ItemNotFoundException
+ FullyQualifiedErrorId : ItemNotFound,Microsoft.ConfigurationManagement.Cmdlets.Rba.Commands.NewAdministrativeUse
rCommand

 

I changed the user account as —

domainuser

‘domainuser’

“domainuser”

fulldomainnameuser

“fulldomainnameuser”

solved 0
Durga Pathak 4 months 3 Answers 188 views Beginner 0

Answers ( 3 )

  1. Hi Anoop, we were able to resolve the issue. We launched powershell in System context and tried above commands and it worked. Thank you for looking into it.

    Best answer
  2. You might have to remove the user accounts and groups which are part of admin (sql and SCcm). Add them back.. or you might still have the old system account added to remote servers.

    It’s worth removing those and adding back.

    Can’t help much without knowing what was the reason for restore and how did you restore etc … can u pls share those details

    • Last weekend, we were running SCCM upgrade 1806 to 1910. After upgrade, RBAC permissions were lost so we reverted VMware snapshot however the permissions didn’t return. So we manually added few users using above command and were able to login. However, we need to do RCA and test the upgrade before asking for another downtime. We were provided a VM for testing wherein we installed domain controller as well as SQL/Prererquisites. We named this computer same as primary site server & installed SCCM on same drive (i.e. C:Program Files…). In the end, we tried to add user manually, its giving this error.

Leave an answer

Sorry, you do not have a permission to answer to this question .