Client Reboot Setting for feature Upgrade Deployment

Question

I’ve attached the SCCM default client reboot setting here.

My customer requirement is machine must go for a reboot after 90min of the deployment with 15min before notification without snooze option.

But , with the following default computer restart settings, the machine is not at all going for any reboot even though I changed the third option value to 60min, but system tray reboot notification appears.

(Note: in the deployment, User Experience – Suppress the system restart is not ticked)

default setting - How To Manage Devices Community Forum - Welcome to the world of Device Management! This is community build by Device Management Admins for Device Management Admins❤️ Ask your questions!! We are here to help you! - Client Reboot Setting for feature Upgrade Deployment

I’ve followed the below ms article but its pretty confusing.

https://docs.microsoft.com/en-us/mem/configmgr/core/clients/deploy/device-restart-notifications#:~:text=In%20the%20Computer%20Restart%20group%20of%20client%20settings%2C%20enable%20the,instead%20of%20a%20toast%20notification.&text=If%20the%20user%20didn’t,a%20notification%20as%20a%20reminder.

 

Guys, please help me with this

solved 0
Rahul Raj 3 months 5 Answers 82 views Beginner 0

Answers ( 5 )

  1. Thank you, Ankit.

    I just found the machine was going in a loop without reboot because, after the feature deployment, the machine was getting into sleep mode.

  2. I would also prefer maintenance windows option.

    Please go through the below article by MS which mentions device restart for Feature updates.

    https://docs.microsoft.com/en-us/windows/deployment/update/feature-update-maintenance-window

  3. Hi Ankit,
    Appreciate your response

    1. I’ve tried with default client settings and custom client settings. In both option its not going for the reboot

    2. Yes, I’ve changed the third option to 30 min instead of 240, even though it’s not going for the reboot in 90 min.
    What I observed, if I set the first option as 60 min and third option anything below 60, it’s going for the reboot in 60 min.

    4. no maintenance windows has been set
    5. in User Experience – Suppress the system restart is not ticked

    • Hello,

      If the client settings were not working then 60 minute reboot should have also not worked.

      1. What is the version of your SCCM ? The reason for this is there are some changes in 1906 and 1902 version depending on deployment deadline.
      ‘Starting in version 1906, the user won’t see a progress bar in the restart notification until the pending restart is less than 24 hours away.’

      2. What is the deployment deadline you are using in the deployment?
      3. Check the resultant client setting on machine from console and see which client setting is getting applied for computer restart.
      4. Also is the client updated to the same version of your SCCM?
      5. I would prefer the setting to ‘yes’ for show dialog box instead of toast notification.

      Try below settings:

      1. Specify the amount of time after deadline – 90 minutes
      2. Countdown notification – 15 minutes
      3. Frequency reminder – 75 minutes
      4. Show dialog box instead – Yes

      If you go through the article you have shared MS has shown how to calculate the timings with examples in Low frequency reminders.

      Best answer
  4. Hi,
    1.Is the default client settings getting applied to the systems or you have made any custom client setting? If you have made custom client settings make changes in that.

    2.Also the frequency which you have set as 240 minutes should be less than the amount of time required for restart which is 90 on your case, change the frequency to 30.

    3.Are you using maintenance windows, check that option also.

    4. For client restart to work make sure you are not suppressing the restart in the deployment of the feature upgrade.

Leave an answer

Sorry, you do not have a permission to answer to this question .