Client Setting – PowerShell Execution Policy is set to All Signed Bypass is not working?

Question

Have you seen this issue before?

I tried to set the client setting to have PowerShell execution policy. It seems not working for me.

 

Have you able to reprod the issue ? or is it working for you all?

When I try to run the following command on Windows 10, it gives a result that all execution policies are undefined.
>> Get-ExecutionPolicy -List
Scope ExecutionPolicy ----- ---------------
MachinePolicy Undefined
UserPolicy Undefined
Process Undefined
CurrentUser Undefined
LocalMachine Undefined

But when I run the following command it works ok.

  • Set-ExecutionPolicy AllSigned -Force
  • Set-ExecutionPolicy Bypass -Force
in progress 0
Anoop C Nair 4 months 2 Answers 103 views 0

Answers ( 2 )

  1. Sure. We can run a script option to change PowerShell execution policy.

    But in my testing client setting policy is not working. Can you re produce the issue?

    https://snipboard.io/cSv4ly.jpg

  2. When the execution policy is set to restricted, Its showing undefined in all scope.

    + https://snipboard.io/wIGmVE.jpg

    – Just after setting up manually Its changing scope for LocalMachine based on inputs, However from Task Sequence or manually Its directly working by passing the parameters within command line.

Leave an answer

Sorry, you do not have a permission to answer to this question .