Collection Membership mismatch

Question

Hello All,

Came up with some weird issue, we are using dynamic application method to install applications during build.

As of now for one machine which we have found till now and can be more, we wanted the machine to be rebuild and applications which were installed previously should not get installed so we deleted the machine from sccm and imported it again( so that machine gets removed from previous collections).

Now when rebuilding the machine the application are still installing, when checking in console it shows machine is part of only two collection which it should be however when i run below sql query in DB it shows machine part of other collection as well.

I am using below SQL query:

Select
Coll.Name,
Coll.CollectionID
from
dbo.v_FullCollectionMembership FCM
join dbo.v_Collection Coll on FCM.CollectionID = Coll.CollectionID
Where
FCM.Name = ‘Machine name’
order by
Coll.Name,
Coll.CollectionID

 

Checking the logs of dynamic app it detects machine part of various collection so it installs it.

solved 0
Ankit Shukla 5 months 2021-02-16T21:53:18+05:30 5 Answers 39 views Admin 0

Answers ( 7 )

    1
    2021-02-17T17:31:00+05:30

    how is your collection membership query looking like? is it a direct membership or query based membership? give us more info on the collection membership type, based on that we can tell what could be the problem

      0
      2021-02-17T23:34:31+05:30

      Hello Rajul,
      That is the problem, in sccm console machine is showing part of only two collections one is ‘All systems’ which is by default and the other one is OSD collection on which task sequence is deployed.

      However when quering the SQL database with the query mentioned it shows me machines is part of few more collections other than those two.

      I deleted the machine twice from SCCM console , imported it back again with GUID and imaged the machine still the same results.

Leave an answer

Sorry, you do not have a permission to answer to this question .