collection Membership update issue in SCCM

Question

HI Everyone,

I hope everyone is safe and healthy!!

Need your expertise regarding an issue are are facing within our environments where multiple collections in our production are in the state of being updated but none of the updates ever.

Based upon checking we found we have more than 370 collection with the incremental update active but this issue started happening recently we even had more than 500 incremental update which we got down to around 270 as for now. Upon checking colleval.log it is indicated that all the collection are queued up and are in the process of updating.

We even restarted Sql server but still these collection are not being updated.

Kindly suggest what could be done here. Hoping to hear back soon on this.

Regards,

Shashi Dubey

solved 0
Arvind Dubey 4 months 5 Answers 90 views Beginner 0

Answers ( 5 )

  1. Collection eval tool is the best one to troubleshoot problematic collections.

    My recommendation using Collection eval tool – try to find the problematic collection and remediate that collections update schedule…

    https://www.anoopcnair.com/sccm-collection-evaluation-viewer/

    Best answer
    • HI Anoop,

      I did that as per your instructions and problem got solved :).

      There was a specific collection which was taking more than usual time to evaluate and keeping other collection to be held in the waiting queue.

      We found it and removed the query and added the device found using direct membership and since it was a excluded collection we excluded the member using direct method and issue is resolved.

      Thanks again for your amazing guidance and sharing vast experience with me :).

      Hope to have your continuous support going ahead:).

      Regards,
      Arvind

    • Thanks a tons Anoop again for being the beacon 🙂

      Thanks,
      Arvind

  2. Hi,

    What is you Environment Infrastructure are you having CAS? If yes then I am assuming that replication link is working fine.Also assuming the performance of your SQL server is good and not under heavy load,because i have seen that Server performance also effects this. I have multiple primaries in my environment and still have this issue on one of the primaries(dealing with it as it is very old physical box).

    If you want the collection to evaluate just restart the Collection evaluator component it should again start to evaluate, keep monitoring the COLLEVAL.box in inboxes and see the files are processing.

    As per Microsoft’s best practices we should not having more than 200 incremental collections in the environment.so the first approach would be to bring down the numbers.

    1. For Microsoft Best practice on collection you can consider below article:

    https://docs.microsoft.com/en-us/mem/configmgr/core/clients/manage/collections/best-practices-for-collections

    2. If you want to query incremental collections and change the evaluation in bulk follow below post which shared recently.

    https://forum.howtomanagedevices.com/endpointmanager/configuration-manager/sccm-collections-are-not-updating/

    3. You need to identify which collections are taking longer time to evaluate and first get rid of them use ‘Collection Evaluation Viewer’ to identify those collections. Check if there are any collection which have membership of query rule. You can use below article for collection evaluation viewer by anoop.

    https://www.anoopcnair.com/sccm-collection-evaluation-viewer/

    Try above options and see if can find out something which will help you in fixing the issue.

    • HI Ankit,

      Sorry i missed your reply and bumped into just now :).

      i didn’t have the CAS in my environment but a single primary site supporting around 13000 clients. And yes you are bang on as the SQL server was under load and the TEMPDB size of the disk was continuously getting full causing the space issue as the files under inboxes colleval.box was taking more space than usual.

      However we did restart the Colleval component and it worked initially but major collections had the hours glass on it.We had the incremental over 200 but brought it down to 120 now 🙂 but even thought we had issue and problem persist.

      Like you suggested we did use the “Collection Evaluation Viewer” and found one of the collection was taking more than usual time eating all the space.we tried deleting it but it was used to exclude certain no of machines for office deployment in our production environment.

      Since Query was the issue we copied collection to a excel deleted the problamatic collection made the new collection and added device using direct rule and had them excluded and it fixed the issue.

      I want to thank you too for this amazing insight and yes this could really help some other is future with the same issue.

      Thanks for the wonderful explanation and hope to have your assistance too going forward :).

      Regards,
      Arvind

Leave an answer

Sorry, you do not have a permission to answer to this question .