collection update issue with ad user sync

Question

I have a weird issue with my ad user sync. I had a few test collection based off of a user group that looks fine but then I had a machine collection of the user from the user groups primary machine. this has been working fine for years.
All the sudden I noticed there are only 3 machine in the machine collection but 14 people in the user group. I ran a sql query an I have null data all the sudden.
The user account are all pulled from one domain YE but all the sudden I am seeing CO domain for user accounts and that pulls in the date I need.
I looked in adusrdis.log and doen see any erros. what would be the best location to look? I only have the sync coming from on-prem cloud ad sync is disabled and i am on 2103 hotfix kb10582136

Posted by Joe Terracciano in HTMD FB Group No photo description available.

in progress 0
Vidya M A 2022-03-04T20:14:17+05:30 1 Answer 43 views 0

Answer ( 1 )

    0
    2022-03-04T22:54:20+05:30

    Replied by Joe Terracciano
    Corjan seems like I just got reports that some of our reports that used to work now are not pulling in the user data properly anymore. just curious are you using the computer account to scan ad?
    I just switched it to use my account as a test and now all the missing data has come in and also fixed the wrong domain name.

    Replied by Corjan de Vos
    Joe Terracciano no we are using an service account for scanning. But it is very interesting information. I’m going to check that tomorrow. Thank you very much for the information!

    Replied by Joe Terracciano
    Corjan yea once I switched after the scans my data came in. I switched back to the computer account and a service account and it worked fine. I am leaving it to my original setting to see if it breaks again at all.

Leave an answer

Sorry, you do not have a permission to answer to this question .