Cumulative update not installing

Question

Found a server in which any cumulative update is not geting installed. Could see that only the MS office updates and servicing stack updates are getting installed every month. Cumulative updates install, but after the reboot, it fails to change to ‘Installed’ state, throwing an error cod – 0x800f0922. Tried dism reset, and sfc scan. Facing the issue in Windows server 2016. Could you please help on this.

solved 0
Anusha Naitrav 3 months 5 Answers 102 views Beginner 0

Answers ( 5 )

  1. No reply hence closing the thread

  2. What about antivirus on your server , also have you checked for the updates which you are installing does it has some prerequisites?

    Best answer
  3. Tried the following for troubleshooting.
    1. Sfc scan done
    2. DISM restore done
    3. Reinstalled .net framework 3.5 and 4.6
    4. Renamed software distribution folder, catroot2
    5. Tried to install old cumulative patches, getting the same error after reboot (also, when the server comes up online, it says it is undoing the updates)
    6. Windows update troubleshooter – It couldn’t fix the issue – windows update database corruption.
    7. CBS log error states: SEVERAL HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE

  4. Look for errors in cbs logs located at C:windowslogscbscbspersisitent***.log
    Search error and failure you will get exact reason of failing. another way to find out is C:windowslogswindowsupdate

    go through this article if this helps https://social.technet.microsoft.com/wiki/contents/articles/37901.windows-updates-failed-to-install-with-error-code-800f0831-in-windows-server-2012-r2.aspx

  5. Haven’t seen this issue but reading articles redirects it’s related to low space on system reserve partition or .NET installation.Check if .NET feature is enabled or not.

    Check below article and see the steps of they help, it is for windows 10 but troubleshooting will be same.

    https://www.howtoedge.com/fix-update-error-0x800f0922-in-windows-10/

Leave an answer

Sorry, you do not have a permission to answer to this question .