Fix SCCM Admin console silent command line issues

Question

‪anyone get the following command line working 🙂 or am I missing something? #sccm #configmgr #memcm 😇‬

‪ConsoleSetup.exe /q TargetDir=”%ProgramFiles%ConfigMgr Console” DefaultSiteServerName=MyServer.Contoso.com‬

‪https://docs.microsoft.com/en-us/mem/configmgr/core/servers/deploy/install/install-consoles‬

 

I couldn’t make this working ✅

solved 0
Anoop C Nair 7 months 12 Answers 739 views 0

Answers ( 12 )

  1. It was because of a pending Teams installation

    Got that details when I tried to install it without the silent switch

    Best answer
  2. ConsoleSetup.exe /q TargetDir=”C:\\Program Files\\ConfigMgr Console” DefaultSiteServerName=MyServer.Contoso.com

  3. Anoop C Nair
    Msi params need to be passed in /V.pls try below cmd,if still error try changing msi params to caps(TARGETDIR)

    ‪ConsoleSetup.exe /q /V”TargetDir=\”%ProgramFiles%ConfigMgr Console\\” DefaultSiteServerName=MyServer.Contoso.com”

    • Is there any space needed between /V and parameter

      ConsoleSetup.exe /q /V ”TargetDir=”%ProgramFiles%ConfigMgr Console\” DefaultSiteServerName=MyServer.Contoso.com”

      • I tried both

        ConsoleSetup.exe /q /V ”TargetDir=”%ProgramFiles%ConfigMgr Console\” DefaultSiteServerName=MyServer.Contoso.com”

        ConsoleSetup.exe /q /V”TargetDir=”%ProgramFiles%ConfigMgr Console\” DefaultSiteServerName=MyServer.Contoso.com”

        No luck

  4. Hi,

    Try this below command line.

    ConsoleSetup.exe /q TargetDir=”C:\Program Files\ConfigMgr Console” DefaultSiteServerName=MyServer.Contoso.com

    Thanks
    Karthikeyan

  5. It seems the backslash is not pasting for me as well…

  6. I think it should be

    ‪ConsoleSetup.exe /q TargetDir=”%ProgramFiles%\ConfigMgr Console” DefaultSiteServerName=MyServer.Contoso.com

    Have you missed the ‘\’ in copy and paste?

Leave an answer

Sorry, you do not have a permission to answer to this question .