Machines not rebooted even supress reboot option is not enabled after patch deployment

Question

Hi all,
I have set manadatory (required) patch deployment 15 days back to 10000 machines without suppressing reboot

But, we have found around 500 machines are pending from reboot from more than a week

Our reboot client setting is set to 3 Hrs

Please help me in sorting why these machines not rebooted automatically

solved 0
kapil kandakatla 5 months 3 Answers 111 views Beginner 0

Answers ( 3 )

  1. Both Anoop and Jitesh have provided some valuable info.

    For your servers, I hope you are using Maintenance Windows. If you are and if your MWs are less than the 3 hour reboot time, then they are likely not going to happen. Create a new Client Setting for your server collections with a much shorter reboot time, like 15 minutes.

  2. First thing I shall check maintenance window setting and RebootCoordinator.log

    Can you check the policy in the registry

    HKLMSoftwarePoliciesMicrosoftWindowsWindowsUpdateAU value?

    AlwaysAutoRebootAtScheduledTime
    REG_DWORD
    0: disable automatic reboot after update installation at scheduled time
    1: enable automatic reboot after update installation at ascheduled time

    AlwaysAutoRebootAtScheduledTimeMinutes
    REG_DWORD
    15-180: set automatic reboot to occur after given minutes

    AUOptions
    REG_DWORD
    2: notify for download and notify for installation of updates
    3: automatically download and notify for installation of updates
    4: Automatically download and schedule installation of updates
    5: allow the local admin to configure these settings
    Note: To configure restart behavior, set this value to 4

    NoAutoRebootWithLoggedOnUsers
    0: disable do not reboot if users are logged on
    1: do not reboot after an update installation if a user is logged on
    Note: If disabled : Automatic Updates will notify the user that the computer will automatically restart in 5 minutes to complete the installation

    More details – https://docs.microsoft.com/en-us/windows/deployment/update/waas-restart

    Best answer
  3. Hello Kapil, As you already updated you haven’t suppressed reboot.

    -Hopefully you already verified the client Restart Settings, checked User Experiences > Device restart behavior.
    – Validate if there’s any overlapping settings are not applied to machines.
    – Analyse RebootCoordinator.log

Leave an answer

Sorry, you do not have a permission to answer to this question .