PXE Boot 32-bit boot image for Windows 10 32-bit OS install

Question

Hi All

Ran into an issue with a customer last week and just wondering if anyone has any ideas.

Customer currently deploys 64-bit Windows 10 using ConfigMgr through PXE boot configured through one of the DPs. All working well.

The customer has a requirement to use 32-bit OS deployed also through PXE however I have noticed that when a UEFI 64-bit machine boots it only receives the x64 boot image.

I have configured a specific task sequence to install 32-bit OS and have also specified the x86 boot image for that particular TS but my issue is when the machine reaches out to the PXE server it loading straight the x64 boot image.

I have tried to adjust the settings on the client machine in UEFI such as turn off secure boot, choose legacy BIOS but have not been successful.

Ideally for the 32bit deployment the customer wants to leverage the task sequence steps that apply for 64-bit on the 32-bit machine such as BitLocker, would that be possible?

Any advise on setup on the client machine and how to get the machine to boot the x86 boot image would be grateful. The machines in question are fairly recent Lenovo laptops.

Thanks

in progress 0
isotonic_uk 3 weeks 3 Answers 49 views Beginner 0

Answers ( 3 )

  1. Haven’t come across this kind of scenario but one of question article shows below solution.

    The below point is for unknown computers but you can also try two different collection and deploy different task sequence accordingly.

    “I created two collections, called 64-bit deploy and 32-bit deploy. I moved the x64 Unknown Computer object and the x86 Unknown Computer objects into the appropriate collection. I then deployed the Task Sequences to the appropriate collections instead of to the default Unknown Computers collection.

    Now I get the correct architecture downloaded to the correct machines”

    • Great, thanks for that.

      I get that from the point when picking the task sequence it will choose the right boot image but my issue is when pressing F12 it defaults to the X64 boot image. I am guessing to resolve to that, thats more what is setup on the IP helpers or DHCP options side?

  2. Unfortunately I don’t have much idea about this scenario… I’ll let others to comment if they have done experience

Leave an answer

Sorry, you do not have a permission to answer to this question .