SCCM 2002 Upgrade Issue

Question

Dear All,

 

I am upgrading SCCM Infrastructure to 2002. CAS upgrade is installed (Post Installation Pending), Primary Site upgrade (post installation pending) installed, however Primary 2 is stuck last 8 hours. Primary 2 Status is Installing status message Extracting update package. CMupdate.log – cmupdate.boxdirectories messages will be pulled in 600 seconds… It’s a loop…

Rebooted the servers.. no fix. Checked Hman.boxCFD single .esc file in all servers. Component Update service is getting stopped automatically due installation is stuck, tried restarting it.

Need urgent help please if anybody encountered this issue. I am on 9910693493 whatsapp

 

Thanks,

Ravi

solved 0
Ravi .S. Mishra 4 months 10 Answers 115 views Beginner 0

Answers ( 10 )

  1. Dear All and Anoop,

    It has been 4 days and 3 sleepless nights for me to get SCCM issue to be fixed (Sort of Vacations from operations and governance) 🙂

    Issue: SCCM primary site CB 2002 upgrade got stuck.

    Solution:

    1. Call logged with CritSit
    2. Initial 13 hours just a waste with Tier1 and 2.

    Tier 3 – Dheeraj from MS
    3. PRIMARY 2 was pointing to Primary 1 in registry Site component threads. Restored from site backup. (CMupdate.log)
    4. SCCM cert chain broken. Dropped cert from Primary 2 and imported cert from CAS manually. (RCMctrol.log)
    5. Replication stopped enforced replication. Didn’t bwork.
    6. Primary Site recovery since CAS and Primary 1 was updated with 2002.
    7. Tables updated and recovery failed after an hour recover operations.
    8. Forced replication from primary site for the changes.
    9. Took 19 hours to complete the replication and fixed MP. (RCM log and MP control log)
    10. Everything was ok.
    11. Post 1 hour of all fixes SMS_executive service got uninstalled with no reason from Primary Site 2. (Sitecomp log)
    12. Intiated Bootstrap process, all fix d.
    13. Post 3 hours of operations SMS_executive of Primary 1 got uninstalled. Initiated the same process to recover. (Site comp log)
    14. Logs of server sent to MS for the review for the reason (pending).
    15. Monitoring SCCM Infrastructure now hope will be good.

    Thanks,
    RSM

    Best answer
  2. Thank you all ! Waiting for the fix 🙂

  3. Dear All

    Thank you suggestions and thanks Karthik for a quick call. I am working with MS CritSit last 13 hours and will share the findings in the forum once the issue is fixed.

    • Harjit Sir 🙂 😀 Easiest fix for all these problems 🙂 Sounds good.

      Ravi S Mishra Ji Did you read this blog? I have tried covering as much as possible in that article along with logs screenshot.

      https://www.anoopcnair.com/fix-configmgr-secondary-server-upgrade-issue/

      It’s talking about secondary but have seen engineers referring it for other site upgrade as well as DRS.

      As Anoop Said DRS is complicated. But we can try once you done reading that article and say that’s not your CPU Of TEA.

      Since you have reached us so we don’t want to disappoint you. Whenever you have time then we can quickly have some live troubleshooting (No Guaranteed Fix). I am in IST. After that we can summarize everything and update this page so everyone will know what we did.

  4. Hi,

    is it all sites post-installation is in the pending state? have you checked the broker service is running in your site servers?

  5. Hi,

    Please restart the server and check the status.

    Thanks
    Karthikeyan

  6. Hello Anoop,

    First thing I did to follow the link you shared before posting the request. My Service Manager is in vacation to Italy .. Indeed from logs i can see stuck site is updated but replication is down between CAS and Pri 2 and the status is not updated. Post Installation task also got stuck…

    Do you have any plan to train admin like us on DRS.. and to help in expansions to deal such cases..

    Thanks,
    Ravi

    • It’s very difficult to have troubleshooting sessions on DRS … Umair Khan got great posts related to same topic. That is the best documentation which you can get about DRS.

  7. The urgent requirement is always a bit tricky via online forums… My recommendation is to raise a support case if you have an outage or urgent requirement to be honest.

    I have seen many similar issues in the past and most of them are because of SQL based replication issues between primary and cas servers .

    https://www.anoopcnair.com/sccm-upgrade-issue-fix-sql-replication/ post by Deb

    Apart from that
    1. Login to primary and check the status
    2. check the sender.log on the CAS and primary to confirm the connectivity
    3. Replication analyzer related troubleshooting

Leave an answer

Sorry, you do not have a permission to answer to this question .