SCCM client installation failure

Question

I am facing client installation failure with error code 0x8004100e.Any help in troubleshooting appreciated.Thanks.

IMG 20200427 WA0002 - How To Manage Devices Community Forum - Welcome to the world of Device Management! This is community build by Device Management Admins for Device Management Admins❤️ Ask your questions!! We are here to help you! - SCCM client installation failure

solved 0
Sujith Ram 7 months 10 Answers 137 views Beginner 0

Answers ( 10 )

  1. Guys,
    Greetings…
    I am also facing the same issue for one of the Client.
    Quick Background : EndPoint ADR was failing…tried things…No Result….Removed the S/W client (Performed a Clean Un-install)
    Tried Client Push via SCCM…

    Following Error reported in ccm logs..
    —> Unable to connect to WMI (rootccm) on remote machine “SCCM Client”, error = 0x8004100e.
    —>Execute query exec [sp_CP_SetLastErrorCode] 2097172941, 0

    Few files did gets Copied to ccmsetup folder…but then nothing comes up…!!
    Environment:
    SCCM v1910
    Client OS : Windows Server 2008 R2
    Note: Its a critical File Server & can not be rebooted.

    Suggest the way forward..

  2. Is it only me or the Screenshot not clearly visible for others too?

    Anyways could you please specify below to break it down in pieces?

    SCCM Version.
    OS.
    Endpoint OS where installation failed.
    Method used to trigger installation.

    BTW the error translates to

    “Invalid namespace

    Source: Windows Management (WMI)
    —–” So if Server class means don’t recreate repository and if Desktop/Laptop then try that.

  3. Hello Sujith, The error comes many times as component inside CCMSetup Directory may get corroupted, Could you please try to delete once and Re-Try!
    Further Please add the screenshots for more clearity, The added one is not properly visible for me!!

    • Or you could try to stop the Windows Management Instrumentation(Winmgmt) service. Change the path C:WindowsSystem32Wbem.
      – Rename from Repository to Repository.old
      – Use the command line option for renaming.
      – Start the Windows Management Instrumentation (Winmgmt) service.
      – CLose opened all programs! Re-try to execute Client Push

    • Tried deleting all CCM related folders. Still same status.

Leave an answer

Sorry, you do not have a permission to answer to this question .