SCCM client installation failure

Question

Hi all,

While installing CCM client manually in server 2012R2 I am getting this error.ccmsetup failed with error code 0x80041013.please provide any troubleshooting clue?

ThanksIMG 20200427 WA0003 - How To Manage Devices Community Forum - Welcome to the world of Device Management! This is community build by Device Management Admins for Device Management Admins❤️ Ask your questions!! We are here to help you! - SCCM client installation failure

solved 0
Sujith Ram 5 months 7 Answers 101 views Beginner 0

Answers ( 7 )

  1. Server Class it is.

    Save it as BAT. Open CMD as Administrator and Navigate to the path where you saved it. Execute it and monitor what’s going on in the CMD Window. After few minutes when it’s done, trigger install.

    @echo off
    sc config winmgmt start= disabled
    net stop winmgmt /y
    %systemdrive%
    cd %windir%system32wbem
    for /f %%s in (‘dir /b *.dll’) do regsvr32 /s %%s
    wmiprvse /regserver
    winmgmt /regserver
    sc config winmgmt start= auto
    net start winmgmt
    for /f %%s in (‘dir /s /b *.mof *.mfl’) do mofcomp %%s
    net start ccmexec

    • Thanks for your reply.But after running batch also same error.
      Machine is server 2012R2 machine.

      • It seems you need to check the WMI health and event logs to get more details now.

        Probably you might need to rebuild WMI repository if it’s corrupted …

        But be careful ….have appropriate change requests before doing this same. This could impact other apps as well

        • Tried rebuilding WMI also.Still same error.
          On scanning found component store got corrupted.
          Did OS repair and
          CCM client got installed.
          Thanks for the replies.

          Best answer
  2. Hi, I suggest before initiating manual installation please try to uninstall the client properly and check all the CCM related folders should be cleaned from the C:Windows location. Also go to registry HKLMSOFTWAREMicrosoft and HKLMSOFTWAREWOW6432NodeMicrosoft path and remove all CCM, CCMSetup and SMS folder. Once everything removed do a reboot. Post reboot try to start installation again. If failed again share the ccmsetup.log.

  3. For this stop the WMI service and rename the repository on below path. C:windowssystem 32webmrepository. Restart the WMI service. Now try to install sccm client.

Leave an answer

Sorry, you do not have a permission to answer to this question .