SCCM collections are not updating


SCCM collections are not updating due to more than 200 incremental collections. How to fix this issue as was working so far.

Answers ( 6 )


    First you need to find out how many incremental collections are there in your environment.

    Use the above query mentioned by Karthikeyan.

    Identify on which ones you need incremental and ones on which you can remove.

    Then use powershell command line to change the settings in one go.

    The acceptable value of refresh types in powershell are :
    1. Manual
    2. Periodic ( Full)
    4. Continuos ( incremental)
    6. Both

    So you can use the below command to change the refresh type from powershell.

    Get-CMCollection – CollectionID “xxx” | Set-CMCollection -RefreshType Manual

    You can change the refresh type accordingly.
    If you use Excel regularly then you know how to do them in bulk using concatenate formula.

    Best answer


    Additional below SQL query will help to find the collection update membership type status.

    CollectionID as ‘ColletionID’,
    Name as ‘ColletionName’,
    case Refreshtype
    when 1 then ‘NoScheduled Update’
    when 2 then ‘Full Scheduled Update’
    when 4 then ‘Incremental Update Update(Only)’
    when 6 then ‘Incremental and Full Scheduled Update’
    End as ‘Refreshtype’
    from v_Collection
    order by refreshtype



    If you still want to fix or resolve the Collection performance with having 200 Incremental collection ? – Does not make sense.

    Strongly recommended to get rid of Incremental collection where possible and get the numbers down (MS Recommended is max 200)

    Additionally, please review some of your query based collections may be some times a bad query in collection will consume heavy resource from Collection evaluator, which is single thread to handle all collection updates.

    Avoid having lot of direct membership for huge collections

    Review collection structures , include , exclude rules and if there any nested kind of exclusions which some times may get into the loop and cause collection evaluator performance.



    As per microsoft advice, incremental collection should not be more than 200+ collections. Please remove incremental option on unwanted collections.

    use collection evaluator viewer tool which is available on your sccm installation folder inside tools folder for more troubleshooting and investigation.

    Please check colleval.log for more information..



    Manju – Always spend time to post questions appropriately …

    I don’t understand what is the question?

    Why there is nothing in the body of the question…

    So to answer your question …there is no hard limit of 200 collections for incremental updates.

    You need to look into colleval.log to get more details,…

    Also, check tool Collection Evaluation Viewer to analyze the collection

Leave an answer

Sorry, you do not have permission to answer to this question .