SCCM report and deployment status showing fake ‘compliant’ status for servers

Question

For some good number of servers mainly 2012 R2and 2016 we are getting fake compliance status.
Sccm showing as compliant but when we manually check the servers we can see that no patches got installed. But if we manually try to install these patches,it will get installed.
I have already tried the following with no success.
1) deleted Registry.pol
2) deleted softwaredistribution folder.
3) Applied latest SSU.
4) verified all required services are up and running from client side.
5) software updates are enabled from client settings.

Please help me on this

in progress 0
Shaiju 1 month 2021-05-14T14:19:37+05:30 6 Answers 30 views Beginner 0

Answers ( 6 )

    0
    2021-05-15T19:54:20+05:30

    Please check if the below mentioned patches are installed on any one 2012 serever. If not then install them on any one 2012 sever first reboot the server then deploy other patches on that server.
    These are the mandatory patches for 2012 R2 server, without these patches other patches will not install on server but in SCCM you will find server as compliant.
    https://www.microsoft.com/en-us/download/details.aspx?id=42334

      0
      2021-05-16T15:40:49+05:30

      this patch is already installed

      0
      2021-05-16T17:12:56+05:30

      There are around 8 patches mentioned in the link I have shared. If all of them are installed as per order mentioned in the link and still you are not able to install the other patches on 2012R2 server than there could be something else which is causing this issue.

    1
    2021-05-14T19:12:09+05:30

    Hi,
    – let me know which month patch are you trying with compliance report
    – The SCCM Client is active and is healthy?
    – what is status of WUA handler log
    – In Report, it is reflecting as compliance means installed or not required state?

      0
      2021-05-14T21:35:17+05:30

      -I am trying previous month patches on our production servers.
      -sccm clients are healthy even I tried repairing one.
      -wuahandler looks clean showing successfully completed scan
      – states 3 report showing kbs as update not required but manual installation is happening for the same Kbs

Leave an answer

Sorry, you do not have a permission to answer to this question .