Steps to remove co-management on Windows workstations for migrated devices.


Hi ,

We have migrated workstation’s from A domain to B Domain. For changing the site code of SCCM we used the below script in group policy.

On Error Resume Next set oSMSClient = CreateObject (“Microsoft.SMS.Client”) ‘if Err.Number <>0 then ‘wscript.echo “Could not create SMS Client Object – quitting” ‘end if ‘Assign client to Servername oSMSClient.SetAssignedSite “P01”,0 set oSMSClient=nothing

All Workstation site code for SCCM client is changed now ,B domain devices got required site code and they are working properly.

But the challenge now we are facing is in A domain co-management was enabled and migrated B domain devices entries are still there in ” A domain “endpoint manager portal. and in B site co-management is not enabled , but it is still showing as co-management is enabled in configuration manager and last sync for the same device is showing recent in A domain endpoint manager portal.

After following below steps still co-management is showing enabled on the B domain client’s.

1. Deleted device from A domain endpoint manager portal. ( Note : In A domain SCCM device is not listed we removed that )
2. Repaired the SCCM client
3. Removed Microsoft Intune client Authentication certificate and A domain certificate’s.

Note : When I am doing complete SCM client cleanup it is not showing enabled , but practically it is not possible to re-install client on 4000 workstations.

Do we have any another way to remove the co-management ?

Co management - HTMD Forum - Welcome to the world of Device Management! This is community build by Device Management Admins for Device Management Admins❤️ Ask your questions!! We are here to help you! - Steps to remove co-management on Windows workstations for migrated devices.

Answer ( 1 )

  1. Domain migration is not supported by ConfigMgr if I’m not wrong. It might work ….if we remove the trusted root key of the existing client/domain…

    But the best recommendation – Uninstall client and install again …

    Best answer

Leave an answer

Sorry, you do not have permission to answer to this question .