Trouble with multiple dependencies

Question

SCCM 1910: I made an app with one primary Deployment Type (“DT1”) and two other DTs that were both listed separately as Dependencies of the first (i.e. not both in a group) – listed as DT2 “AND” DT3.
If I uninstall DT2, it reinstalls it. If I uninstall DT3, it does not. If I uninstall DT2 and DT3, both reinstall.
I could only make it work as I thought it ought by making DT1 depend on just DT2 and then make DT2 depend on DT3.
Any idea what might be going on? Thanks!!
More info: When I uninstall just DT3, AppIntent says it is ResolvedState=None and that DT1 has “dependencies not satisfied”. If I remove DT2 as well, then DT3 says ResolvedState=Installed and then they both reinstall!

solved 0
Cantoris 5 months 2020-11-30T14:55:41+05:30 4 Answers 40 views Beginner 0

Answers ( 4 )

    0
    2020-12-09T14:38:53+05:30

    Originally I set DT1 as dependent on DT2 AND DT3 but didn’t make 2 and 3 dependent on each other – which would seem superfluous if it worked as it looks as though it ought.

    To make it work I had to set DT1 to be dependent on only DT2 and then made DT2 dependent on DT3 separately.

    0
    2020-12-05T09:13:33+05:30

    The dependency which you have added are they also dependent on each other?
    Have you tried the approach on making DT2 and DT3 dependent on each other?
    I have used this in my environment but MS says it should work if they are seperated by AND logic.

    0
    2020-12-01T13:25:25+05:30

    Thanks Ankit.
    My config is already like the first screenshot where it shows the second item in the Dependencies list with an AND.

    0
    2020-11-30T21:23:07+05:30

    Can you check below link hope this helps you to give answer, reply back if it doesn’t.

    https://tjindarr.wordpress.com/2012/05/04/application-dependencies-in-sccm-2012/

    Best answer

Leave an answer

Sorry, you do not have a permission to answer to this question .