After trying to remove device from AAD join , unable to re-add it. Got TPM malfunctioning error.

Question

Hi Team,
I am getting the following error when trying to join device to AAD using dsregcmd /join . After executing the command and opening company portal. I had to enter the account credentials. Then the following error comes up.
how do i fix the error 80090034

Something went  wrong

your computer’s Trusted Platform Module has malfunctioned. if this persist,contact your system administrator with the error code 80090034.

More information: https://www.microsft.com/wamerrors

additional problem information

Error:80090034

The laptop is bit locker encrypted and in bios the TPM is enabled. The device is connected to internet.

Thanks
Vivek

solved 0
technovivek 5 months 4 Answers 181 views Beginner 0

Answers ( 4 )

  1. I failed this issue. After reset the device it got solved.
    Please try reset and re-enroll

    Best answer
  2. What happens when you try to manually join ?

    This is not related to Intune

    I think you are trying to azure ad registration to make machine as hybrid azure ad join.

    Is that correct understanding?

    Machine is domain joined ?

    • I am not doing Azure ad registration.. This is a domain joined device. The history of the issue is. The device is already in joined to azure. But in the company portal the sync button was grayed out and it was written “you must connect the device to work”. Since there was no chance of connecting to work due to current lockdown.

      I tried to remove the device from AAD using dsregcmd /leave and join it using the command dsregcmd /join. But the join was not successful due to TPM error.

  3. Hello, Could you please clear if your credentials are stored inside Control Panel > Credential Manager.

    Check this – https://answers.microsoft.com/en-us/msoffice/forum/all/error-code-80090034/2c968bd7-8f20-4878-83cc-2296e26d5aad

Leave an answer

Sorry, you do not have a permission to answer to this question .