Hide access to the Command prompt(CMD) for users,

Question

Hello, I have a query.

How can I do from Intune, hide access to the command promt (CMD) for users, but have the possibility to launch batch.

Thnaks,

in progress 0
David Lopez 1 month 2021-05-17T18:05:55+05:30 7 Answers 26 views Beginner 0

Answers ( 7 )

    0
    2021-05-17T20:21:50+05:30

    Hello David, Intune allows us to restrict access to Command prompt using below OMA- URI settings –

    OMA-URI: ./user/vendor/MSFT/Policy/Config/ADMX_ShellCommandpromptRegeditTools/DisableCMD

    Value:

    1 = Disable command prompt and BAT and CMD scripts
    2 = Disable command prompt

    https://snipboard.io/5AaMG4.jpg

    + Reference link – https://docs.microsoft.com/en-us/windows/client-management/mdm/policy-csp-admx-shellcommandpromptregedittools#admx-shellcommandpromptregedittools-disablecmd

    If you want to allow users not to search and find the Command Prompt like Start Menu, Search Option, you can remove the shortcuts like – This is not a recommended option.

    “%AppData%\Roaming\Microsoft\Windows\Start Menu\Programs\System Tools\Command Prompt.lnk”

    Let’s give a test and update with your points what you want to achieve for further help.

      0
      2021-05-17T20:29:37+05:30

      OMA-URI: ./user/vendor/MSFT/Policy/Config/ADMX_ShellCommandpromptRegeditTools/DisableCMD
      Data type: String
      Value:

      Note – This setting will only work with the device running with Windows 10 build 20226.

        0
        2021-05-17T21:56:52+05:30

        jitesh,

        I have version 20H2 installed Windows 10 Pro, is it compatible? I don’t know which version 20226 is.

        The configuration policy that you detail is applicable to groups of users as well as devices?
        I have thrown it on the device and it is wrong.

        0
        2021-05-17T22:04:29+05:30

        OMA-URI: ./user/vendor/MSFT/Policy/Config/ADMX_ShellCommandpromptRegeditTools/DisableCMD
        Data type: String
        Value:

        In the value option do I add 1 or 2?

Leave an answer

Sorry, you do not have a permission to answer to this question .