Intune azure AD joined machine login issue


Hi All, I have created 4 VMs in azure using free subscription. 2 machines I have joined in azure AD and 2 machines I did AD registration. Post joined to Azure AD I’m not able to login using Intune credentials. On azure AD joined machine I’m able to login only using local credentials. Can you please help me on this?

Thanks in advance.

Answers ( 11 )


    Anoop I do not have many resources to check this, again I have tried to disconnect and rejoin but that did not work, I have converted the same azure AD joined system to Azure AD registered after that application installation testing is fine. As you said Azure VM’s are bit tricky.

    I do not have any further questions related to this at this point. thanks for assistance.


    It is is the same issue Anoop so was just checking on the same tread, It is Azure VM so bit tricky, I have verified the blog all looks good but do not work as expected. I will check again and let you guys know if there any specific solution to it. thanks.


    My Bad to disconnect we need to use local admin account not azure AD account (Intune).


    Bit tricky I am not able to disconnect the device from the Azure as well, the credentials are not working anymore.


    Hi, I have the same issue, this is just a test VM created and I have done the Intune AD joined, I did go through the above blog, RDP settings are fine, my intune user has valid licence EMS, certificates are good both personal (one day valid) and AAD Token issuer (one year valid), I am using public IP to login I am able to login to the same system with local ID. I am using ID as [email protected] the same works with azure portal and Intune devices shows up fine in both as azure AD joined. I do not get any specific error than login attempt failed.

    Just trying to understand what I am missing, disconnecting and rejoining to domain is good idea?


    Hello Priya, Can you please check the similar thread –

    Please let us update if you have any other query.

Leave an answer

Sorry, you do not have permission to answer to this question .