Domain Join issue During OSD

Question

Hi Anoop/Team,

Hope everyone is doing great and being safe!

I have raised this question before and I was helped in this community so well but unfortunately, I have been facing the newer issue with the domain join during OSD. Need your expertise and experience in getting this addressed 🙂

Upon checking the netsetup log we found the below error:

================================================

NetpValidateName: checking to see if ‘XYZ.global.corp’ is valid as type 3 name
10/07/2020 16:09:48:459 NetpValidateName: ‘XYZ.global.corp’ is not a valid NetBIOS domain name: 0x7b
10/07/2020 16:09:48:459 NetpCheckDomainNameIsValid for XYZ.global.corp returned 0x54b, last error is 0x0
10/07/2020 16:09:48:459 NetpCheckDomainNameIsValid [ Exists ] for ‘XYZ.global.corp’ returned 0x54b
10/07/2020 16:09:48:459 NetpJoinDomainOnDs: Domain name is invalid, NetpValidateName returned: 0x54b
10/07/2020 16:09:48:459 NetpJoinDomainOnDs: Function exits with status of: 0x54b
10/07/2020 16:09:48:459 NetpJoinDomainOnDs: NetpResetIDNEncoding
===================================================================================

A surprise to our beliefs when we use the same Account and password and try to join the domain manually it was successful and it worked. Other logs such as Setuperr are not created and we have the above error only documented multiple times as a final error too.

If someone faced this issue kindly reply so your’s experience and expertise could prove to be helpful for me to fix this issue.

Hope someone’s experience could prove to be helpful.

Regards,

Arvind Dubey

in progress 0
Arvind Dubey 3 weeks 8 Answers 51 views Beginner 0

Answers ( 8 )

  1. Thanks Arvind this was the first answer in the thread that it is due to adapter, but using docking station or any other thing is only a workaround.

  2. Hello Arvind,

    How you are joining machine to domain are you using customsettings.ini, unattend.xml or you are jlining via task sequence step.

    The error resembles with the first boot when machine comes out from winpe. The issue is related to adapter, I have also seen this in past and it happens randomly on few machines there are several article which you follow to add a step to ping the local host for 1 or 2 minute and then again try to join domain.see if that works.

    • HI Ankit

      Yes, you are absolutely right and this happens after the comes out of the WINPE after the first boot.

      We had opened a case with MS too regarding this and like you clearly explained they added a step to ping the local host for 60sec explaining that this time is needed to initialize the NIC card :). and we also moved down the Domain join step to borrow some time additionally.

      It went perfectly fine for some time and again we are seeing this error with the random system but very frequently.

      Are we missing something in your experience?

      is there a better way to address this? or should we look somewhere else too.

      Hope to hear back soon about this.

      Regards,
      Arvind Dubey

      • Hi,
        I didn’t opened a case with as I was facing issue with only two models that are tablet 2 in 1, O tried the step which MS provided to you but it didn’t work so I added the domain join step in customsetting.ini mentioning the path of OU,domain join account and password etc.
        It has worked fine since then let’s see if it goes smoothly or it will again break after sometime

        • Hi Ankit,

          Just a final update on this thread after the mammoth troubleshooting done on this from all viewpoints and we have been able to fix it finally :).

          Having observed the issue with all the models and specifically, domain joins failure we researched and got to know that our computers were unable to retain IPS after botting into full-blown OS after finishing the WINPE, and since they could not retain IP they fail to domain join and it kills the entire process of MP lookup by Ad publishing and since we do not have DNS publishing or WINS our systems were unable to find any MP and entire build process fails.

          Upon further investigation and reading the various article it came to our knowledge that we were reimaging the device using C lan adaptor and sometime after the reboot into the full-blown OS the driver of the C lan adaptor doesn’t get initialized and we have to go for plug and play to have it initialized and then the system would get the IP and complete the build without any issue.

          We tried building the machine using a Docking station and it worked like a charm for us and now we could build multiple machines at one shot without any issue :).

          We have raised the issue with the vendor regarding C lan adaptor and currently using a docking station to build multiple machines and since then we haven’t heard any fuss.

          So for the docking station, we have to be careful when the machine boots into full blown OS and sometimes go for plug and play else system would lose the IP.

          Using RJ45 directly and docking station everything works like a charm and for C lan adaptor we have to go for plug and play during problematic steps.

          Hope this experience helps someone with their troubleshooting so felt worth giving back to this community :).

          Thanks for everyone’s help and time and hope to have this support and experience in the coming time too.

          Regards
          Arvind Dubey

  3. Does it seem to be the DNS issue?

    NSLookup works fine?

    Also, make sure the DNS server has a record for XYZ …

    Manual domain join is working without any work around (host file entry)?

    During manual domain join what was the domain name provided (1 or 2)?
    1. XYZ
    2. XYZ.global.corp

    • Hi Anoop,

      Thanks for your time!

      > Yes, Nslook up works fine in this case.

      >This DNS server Anoop must be having the record of this domain considering it was working fine absolutely without any issue but it started happening from a day or two? If I am missing something should I be looking somewhere?

      > Yes we normally doing the manual domain join without any workaround and it is working fine without any issue only the problem persists with doing it in task sequence during OSD. Kindly guide if I am missing something.

      > While going to the properties in the computer and select the option to join this computer to the domain we select “XYZ.global.corp”.

      Regards,
      Arvind Dubey

    • Dear Anoop,

      Also, we have tried reimaging more than 5 machines today one was successful, and the other all were failed to join the computer to the domain

      It was working before but started happening before a day.

      Regards,
      Arvind Dubey

Leave an answer

Sorry, you do not have a permission to answer to this question .