Enable .NET 3.5 in Windows 10 using TS, Package, Application, Offline Media, Script, Online

Question

Hello Team, Greetings for the day. Hope you all are staying safe.

I need help in one of the task i am trying to do is enable .NET 3.5 for my Windows 10 V 1909. The step getting executed in the TS is failing. This is not model specific. We have several Lenovo Models and it’s failing for all.
If we disable the .NET step then Task Sequence installs the OS on bare metal without any issues along with all applications defined in TS.

I have tried several articles from google to get it done in the TS but unfortunately none are working. Any Help would be greatly appreciated..

Here is my Infrastructure Configuration.

MECM 2006 With Latest Hotfix.

1 Standalone Primary, 4 MP, 2 SUP, 1 FSP, 1 Data ware House, 37 DP’s,  CMG,

Was Anything changed recently : NO

Was it ever working : Yes. Last Month it was. No Change.

Methods tried :
DISM

PS Script
Offline Installer

Enable online: Post TS execution where .NET 3.5 is set continue on error if we try enabling it online then it takes hours.

Screenshot of Error:DOTNET ERROR - How To Manage Devices Community Forum - Welcome to the world of Device Management! This is community build by Device Management Admins for Device Management Admins❤️ Ask your questions!! We are here to help you! - Enable .NET 3.5 in Windows 10 using TS, Package, Application, Offline Media, Script, Online

solved 0
Deepak Rai 3 weeks 5 Answers 63 views Admin 0

Answers ( 5 )

  1. Hello Jitesh and Ankit , Thank you both.

    Ankit Shukla :- That’s the first thing came into my mind to use DISM but WIM modification is restricted in this Infrastructure.

    BTW i figured it out.

    .NET usually goes to internet when used DISM /Online to fetch the CAB and the URL was filtered.

    For us the error was just printing .NET failed but when we started troubleshooting from OS prospective then we found it was going to URL and blocked.

    CBS.log helped to identify.

    Screenshot of the CBS log

    snipboard.io/AXgYOS.jpg
    snipboard.io/GaXF51.jpg

    Just add HTTPS:// in the above links. I believe sharing 2 links in the same answer was giving some trouble in the forum site so i have given as RAW text.

    We opened the port and TS came back to business.

  2. – Just to confirm as you mentioned, Had you tried to create package without program and add Run Command line options with installation command.

    – Not sure! if already done by creating package with standard program & add to TS.

    Assuming the same .Net package executing manually in Windows Version 1909 without any issue.

    If all fine, Try to change the order in Tasksequence and let see how it executing. I also observed these type of behavior with .Net in past.

  3. Hello Deepak,

    Any specific reason for not enabling the feature itself in the wim file itself instead of using a seperate step in task sequence?

    Best answer
    Cancel the best answer

Leave an answer

Sorry, you do not have a permission to answer to this question .