pxe-e23: client received TFTP error from server

Question

I am trying to pxe boot Lenovo ThinkPad T470s using SCCM CB 1910. When we try to pxeboot the machine is erroring as

pxe-e23: client received TFTP error from server.. I have copied wdsmgfw.efi into E:RemoteInstallBootx64, but still the issue is happening. Please provide some advise

solved 0
prasanth_mp 7 months 9 Answers 392 views Beginner 0

Answers ( 9 )

  1. As you ping me on group other machines also same issue , please check if iphelper allow this boot image path,and also check in smspxe log which boot image try to connect (correct boot image as per your location).

    Also check if boot image distributted on particular dp.

    As Jitesh suggest please share smspxe log for further details.

    • Hi Aamir,
      We are using DHCP scope for PXE boot. I dont have access to check it directly. Let me update here once i have confirmation.

      • Please check if DHCP scope is configured properly like ip address of dp and file path is proper . And also check machine is getting correct boot image .As MS. recommended do not DHCP scope . always use IP helper.
        As Jitesh suggest please share smspxe log.

        Best answer
  2. Hello Prasanth, Please check whether do you have any recently BIOS updated ,UEFI & Secure Boot were configured..

    As Suggested by Aamir – Update your BIOS , Please Share the SMSPXE.log for futher details.

    • I am curious about are you getting this issue only with Lenovo T470s ?

      • Hi Jitesh,
        The issue is not on T470s alone. We tried T480s now and the same error happened. SMSPXe.log does not have any entries for machine getting hit from pxe boot.
        Most of the logs are like this

        Begin validation of Certificate [Thumbprint CA27C0FF72C0F6E5416F89652D41BEA123F6F269] issued to ‘{DA9FA031-8DC3-432C-A278-9528A3F793BF}’

        Completed validation of Certificate [Thumbprint CA27C0FF72C0F6E5416F89652D41BEA123F6F269] issued to ‘{DA9FA031-8DC3-432C-A278-9528A3F793BF}’

        • Thanks Prasanth for the quick Update!! This issue occurs due to various reasons, I will be probably verifying the following things –

          РExpecting In the boot image under DataSource РYou selected the Deploy this boot image from the PXE-enabled distribution point. 

          – If the computer name with MAC exist for, you could try to delete the entries.

          -Is “wdsmgfw.efi” file was missing earlier ? and copied successfully as you already mentioned.

          -Any success on other machines, If Yes > Try to change the BIOS in Affected systems.

          Please share the more details with us to help for further troubleshooting, It would be great if could able to attach the logs as well.

          • Hi Jitesh,
            Thanks for the advice. We found the problem.
            Network team has pointed out our test server in the DHCP scope instead of the Live CB server.We have asked them to change it to the correct Server. Hopefully the issue will get fixed once the change has been made. Thank you once again for the advise on this issue.

  3. Please check if getting same error on other machines.

    Ensure latest bios version and proper boot setting in BIOS.

Leave an answer

Sorry, you do not have a permission to answer to this question .